Study: 80% of People Run Vulnerable Versions of Flash and Acrobat

Earlier this year, Adobe said it will stick to a quarterly relese schedule for security updates, but apparently that isn’t nearly enough. According to research published by Trusteer, 79.5 percent of the 2.5 million users of their Rapport security service still run a vulnerable version of Adobe Flash and 83.5 percent run a vulnerable version of Acrobat.
“Two weeks after Adobe released a critical patch for Flash and Acrobat Reader our research shows that almost 80 percent of Internet users are still vulnerable. This is the biggest security hole on the Internet today and the failure of Adobe to address it in a timely manner is extremely troubling,” Trusteer wrote in its report.

Trusteer was critical of Adobe’s update mechanism, saying that while Adobe’s Flash site identified machines that weren’t running the latest version of Flash, it failed to issue a notification that the system is at risk and “did not strongly urge that the update be installed.”
Read the full report in PDF form here, and trade in that bloated Acrobat Reader for a leaner alternative here.

Leave a Reply

Your email address will not be published. Required fields are marked *